We are pleased to report that the major delivery disruption affecting SMS messages targeted at Unitel subscribers has been fully resolved.
As of today, all outbound SMS traffic to Unitel destinations (+244 92x, 93x, 94x, 97x) is operating at full capacity with normal delivery speeds and success rates.
Resolution & Monitoring Details
Our SRE and network engineering teams conducted extensive end-to-end dispatch tests and verified that upstream connectivity with Unitel's infrastructure has been stabilized.
Unitel Destinations: Fully operational. Message queues have been cleared.
Africell & Movicel Destinations: Remained 100% operational throughout the incident window.
Next Steps
We will continue to actively monitor latency and delivery success rates across all carrier links to ensure ongoing stability. No further action is required from client applications.
Thank you for your patience and support during this service restoration period.
Resolved
We are pleased to report that the major delivery disruption affecting SMS messages targeted at Unitel subscribers has been fully resolved.
As of today, all outbound SMS traffic to Unitel destinations (+244 92x, 93x, 94x, 97x) is operating at full capacity with normal delivery speeds and success rates.
Resolution & Monitoring Details
Our SRE and network engineering teams conducted extensive end-to-end dispatch tests and verified that upstream connectivity with Unitel's infrastructure has been stabilized.
Unitel Destinations: Fully operational. Message queues have been cleared.
Africell & Movicel Destinations: Remained 100% operational throughout the incident window.
Next Steps
We will continue to actively monitor latency and delivery success rates across all carrier links to ensure ongoing stability. No further action is required from client applications.
Thank you for your patience and support during this service restoration period.
Monitoring
We are currently experiencing a major disruption in SMS message delivery targeting Unitel subscribers due to a confirmed nationwide network incident on the operator's infrastructure.
Operator Announcement Summary
Unitel has officially issued a public notice confirming that their telecommunications network is currently experiencing technical instability affecting voice and data services nationwide. Their technical teams are actively working on resolving the issue and restoring normal operations.
Current Platform Impact & Guidance
Unitel Destinations: Messages sent to Unitel numbers (+244 92x, 93x, 94x, 97x) via our SMS gateway are currently failing or encountering severe delivery delays due to the upstream operator outage.
Africell & Movicel Destinations: All outbound SMS messages targeting Africell and Movicel subscribers remain fully operational with normal delivery rates.
Next Steps & Monitoring
Our engineering team is closely monitoring the situation alongside our upstream carrier providers. We will conduct continuous connectivity and dispatch tests to verify service recovery as soon as Unitel restores network stability.
A status update will be provided within 6 hours or as soon as significant progress is reported by Unitel.